July 15, 2012

[solved] Google Analytics : Tracking not installed

I have been using Google analytics for over four years. I was quiet proficient at integrating analytics code and used it in more than one site (for example, http://get-a-solution.blogspot.com). However, recently I faced problem at google analytics integration and it was really disgusting. I copied the tracking code from analytics, paste it before the closing head () tag like I did on my other site. But it did not work. The following error showed up :"Tracking Not InstalledLast checked: Jul 14, 2012 9:27:34 PM PDTThe Google Analytics tracking code has not been detected on your website's home page. For Analytics to function, you or your web administrator must add the code to each page of your website."



 Analytics kept telling me tracking is not installed. I waited for few hours, refreshed analytics page repeatedly and checking the page source of my website to see if everything is okay.
And everything was okay (!) in my page. I googled this problem and found mistakes other folks had been doing. I did not put wrong code, did  not change profile id, did not disable javascript, did not put wrong URL at analytics settings. The online solutions were not applicable for me. I got frustrated due to repeated failure.

Then it occurs to me, almost suddenly. I have chosen a naked domain name for my site. It was http://shoppingdhaka.com . It will work fine when you type http://www.shoppingdhaka.com at the browser. But it is really a naked domain, meaning you actually do not have that WWW in the domain name. And this was actually my mistake. I put a WWW in the analytics sprofile url box. 

The tracking not installed message was gone seconds after I removed that WWW from my URL. See the image below to find where I made the change.
Tracking Not Installed:solution
See that default URL box? Just remove the WWW from this box. So www.dhakashopping.com should be just "dhakashopping.com". It will work if you make no other mistakes.




34 comments:

  1. thank you! your post saved me after hours of frustration!

    ReplyDelete
  2. i faced the same issue and then i found this link http://webloggerz.com/tracking-not-installed-google-analytics/

    ReplyDelete
  3. This comment has been removed by the author.

    ReplyDelete
  4. AWESOME!!!!! I worked on this for days!!! Your solution worked in under 30 seconds!

    ReplyDelete
  5. Thank you very much. This really helped. Why isn't there a tip from google about this????

    ReplyDelete
  6. Mine was already http://xxxxxx.blogspot.com/
    But it never changed the status :(
    Any ideas why?

    ReplyDelete
    Replies
    1. I really dont know what is happening in GA. It behaves really weired these days.
      You can try this http://qyerty.blogspot.com/2012/10/analytics-tracking-problem-in-new.html

      Delete
  7. I have been frustrated for days trying to get GA to work for my DW-HTML based website. I have tried numerous methods - put the script before the ending head tag; put the script before the ending body tag; even tried inserting the script in a php file and calling it from my html with an include once. I also tried your method of removing the www from the url in Property Settings, but it still says Tracking Not Installed. I have been to numerous forums and support guides, and I still can't get it to work. And, it sounds like there are many frustrated users with GA with their Tracking Not Installed either. The instructions provided by Google sounded straightforward, but I'm pulling my hair out trying to get this to work! Any suggestions or feedback would be much appreciated! Thanks in advance!

    ReplyDelete
    Replies
    1. let me know if you succeed. Dont hesitate to ask if you need any help

      Delete
  8. do i have to wait for 24 hours to get rid of this error? :(
    ive ckeck everything but still tracking not installed error :(

    mytrickland.blogspot.in

    ReplyDelete
    Replies
    1. Have you tried this?
      http://qyerty.blogspot.com/2012/10/analytics-tracking-problem-in-new.html

      Delete
  9. i tried this method but it still didn't work for me
    Android Helova

    ReplyDelete
    Replies
    1. Are you trying to use any kind of old code? I visited your page but found a different type of analytics code inserted on your blog. I found this:

      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

      ga('create', 'UA-XXXXXX-X', 'androidhelova.blogspot.com');
      ga('send', 'pageview');



      However, I was expecting this:



      var _gaq = _gaq || [];
      _gaq.push(['_setAccount', 'UA-XXXXXX-X']);
      _gaq.push(['_trackPageview']);

      (function() {
      var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
      ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
      var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
      })();



      Can you recheck the code again?

      Delete
    2. Hi Salaken bingo,

      I came to this thread because I was getting the tracking not installed error. However you post here has solved my problem. GA was asking me to enter code in exactly the format that you quote for androidhelova. I copied the code that you quote above (changing the UA number of course)and now it works! So thank you!

      But I'm still confused - why is GA giving us the wrong code in the first place? As I say, the code starting "(function(i,s,o,g,r,a,m)" is the code supplied by GA!

      Delete
    3. Hello TIM,
      Probably you are looking at old version of the code, or somewhere in your setting it tells google to give you old fashioned code. Can you check your analytics setting?

      Delete
    4. Hi, thanks, this worked for me. I don't understand why google is giving non-working code though.

      Delete
    5. Thank you so much. Finally got GA to work by changing the code.

      Delete
    6. Thank you for that code. I thought that the "www" might've been a problem, but it wasn't. In fact, the code GA gave me was the old code and not the code you mentioned in your comment here. I put that in my site and GA recognized it asap. Thanks so much!

      Delete
  10. This worked for me. Thanks very much

    ReplyDelete
    Replies
    1. I am really struggling with this. removed the www and still saying tracking not installed any other tips?

      Delete
    2. You can try this http://qyerty.blogspot.com/2012/10/analytics-tracking-problem-in-new.html

      Delete
  11. I actually just had the REVERSE of this problem - tracking wasn't working for me, but it was because the 'www' was NOT in front of the domain name. Once that was added, the message of 'tracking not installed' remained, but real-time tracking began immediately. From what I've read it can take a day or two for the "not tracking" message to go away.

    Thanks for the info that led me to solve this problem!

    ReplyDelete
  12. I have create a google analaytics account and am having the same problem with the new GA code snippet, am sure that the application has executed the snippet but not sure why is it still showing the status as NOT INSTALLED. My website is an intranet site and doesnot have www. I have gone through this steps: http://qyerty.blogspot.in/2012/10/analytics-tracking-problem-in-new.html but I could not get follow it correctly as the UI seems to be different in GA now.

    Below is the code snippet i got can you please let me know any tweeks:

    script
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

    ga('create', 'UA-XXXX', 'bp.com');
    ga('send', 'pageview');
    script

    ReplyDelete
    Replies
    1. Hello chinmay,
      You are using an old code. Can you try with new GA code snippet? If GA tracking does not work even after using new GA code, please go through all posts in my blog on GA. I believe that will help.

      Delete
  13. Hey, I too had the same www problem initially. I corrected it and tried the new code (with ga.js) check it at www.amoghdesai.com

    Now I can see realtime clicks but the Tracking info still says "Status: Tracking Not Installed". I have also checked my site source and the script is loading with no issues. Do you have any suggestions ??

    ReplyDelete
  14. So glad I found this page! I got rid of the www. like you said and changed the code I was using to the one you suggested above! Was very frustrated until now, thank you very much !

    ReplyDelete
  15. Thank you - the "new" code snippet did the trick!

    ReplyDelete
  16. Thank you so much ....i just switched to the new code...i don't know why google is making us use the old code..

    ReplyDelete